0

After upgrading Pyramid, it is not possible to access Pyramid using the URL host name defined in IIS

ISSUE:

After upgrading a Pyramid install that uses IIS, the site is no longer accessible, please check that the following is correct:

1)

Open IIS >Double click on the server name(1)>Double Click on "Application Request Routing Cache"(2)
  

Make sure that the box "Enable proxy" is ticked and if not tick it (3)>Click on Apply(4)

 

2)

Check that the Rewrite URL rule is correct on the Pyramid2018 website. Double click on the Pyramid2018 website >"URL Rewrite">"ReveseProxyInboundRule1"

The Rewrite URL should be "http://localhost:8181/{R:1}" as shown below, if it is not, please update it, click apply and do an IISRESET.

 

Reply Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
reply to topic
Like Follow
  • 2 wk agoLast active
  • 59Views
  • 1 Following