Can you switch off Totals for specific columns in a Matrix Grid

I have this grid

and don't want Totals for the O'Stock columns. I tried using Colour to no avail, all help greatfully received

1 reply

    • Senior Director of Product
    • Ian_Macdonald
    • 3 mths ago
    • Reported - view

    Hi Steve,

    We are currently enhancing the totals and subtotals options and we will have a "No Totals" option by Column/Row/Measure. This will be available in a later release of Pyramid.

    In the meantime, yes, you can, through the judicious use of text formatting and conditional formatting. I've recreated your grid layout, albeit the data is a bit different, but I have an outer dimension member, Bikes whose measures are all zero and a Total line.

    First thing is to remove the formatting on the Totals. from the Grid sub menu click on Total Formatting to turn it off:

    Highlight the Totals row, choose "Rows" in the dropdown on the formatting panel and set the background to white:

    Then Choose "Rows" from the drop down and again set background colour to White:

    For our effect to work, we need to turn off the "Readability" switch. Go to the Design sub menu, click on Readability and choose "Off":

    Now click on the Column header whose group of measures you want to hide the sub totals, in my case, "Bikes". Choose "Data" form the drop down and set the FOREGROUND colour to white. The text will disappear:

    Now right click on "Bikes" (or O'xxx in your case), choose "Conditional Formatting/Bikes/Sale/Foreround Color/Color Positive Negative". Repeat but for Expense, and again for Var.

    Repeat again for the other outer dimension Members, but only choosing Var, so Accessories/Var, Clothing/Var and Components/Var. You should have something like the following:

    Two last things to do. We don't need the legends, so we'll remove those and we want the conditional formatting to apply to the totals for the Var column outside the Bikes Member. This is how the subtotals are hidden. We've set the foreground and background to white, then applied conditional formatting to the columns, but not applied it to the totals. 

    Right click on the Orange chip, Var, Accessories in the Color Drop Zone and choose to "Edit Color Logic":

    Check the "Include Totals" and uncheck "Show Legend":

    Do the same for Var, Clothing and Var, Accessories. For the other Color chips just uncheck "Show Legend".

    We now should have the finished article:

    Hope that helps!


Content aside

  • Status Answered
  • 3 mths agoLast active
  • 1Replies
  • 69Views
  • 2 Following