0

Configuring Open AI for Gen-BI

Hello Community Experts!

We are trying to configure Open AI on our demo server. And so far, no luck. Steps we take:

  1. Get Open AI API Key. In API Keys page we generate a new project key. We copy the key
  2. In Pyramid we click on "Add LLM Provider", paste the key in the respective field and provide the key name corresponding to the name in Open AI (doesn't seem important, but for consistency).
  3. Before clicking Apply, we click on "Test". Tried the default test message and custom, the result is the same - Response error. We think the problem is here.
  4. Regardless, we apply the LLM Provider and it appears in the list.
  5. In AI Settings we tick the box for "Enable Generative AI Features" and select our LLM Provider from the previous step. Then we click "Apply".  The message is "Saved Successfully". Navigating from this page and back keeps the settings.

To test, we click on New Presentation and it opens the Theme Chooser. We click on a Theme and on Create. However, the "AI Pyramid" at the bottom is greyed out, as before. We attempted restarting DS/ML Service and NLP service without any success. 

Has anybody successfully configured this functionality? Can you advise what should be tried else?

2 replies

null
    • Galit_Backlund
    • 2 mths ago
    • Reported - view

    Hello 

    To configure the LLM Provider successfully, please ensure that both of the AI settings are enabled ('Enable Generative AI and Natural Language Operations' & 'Enable Generative AI Feature'), and that the correct LLM provider is selected under the 'AI Settings', as shown in the image below:

    Hope that helps.
    Galit Backlund

    • Dmitri_Kanounnikov
    • 2 mths ago
    • Reported - view

    Hello  ,

    Thanks for your response. That was our mistake - we had the default chatbot engine instead of the Open AI one. This addressed the problem of access to AI, i.e., now the pyramid in the bottom right corner is clickable. Another point that wasn't expressly stated anywhere, there must be a credit balance on Open AI API account for this to work. Having all these in place made it happen!

    Thanks a lot for your help!

Content aside

  • Status Answered
  • 1 mth agoLast active
  • 2Replies
  • 60Views
  • 2 Following