Geospatial map using german zip codes

Hi folks,

I try to use the geospatial map visual on an AS cube and have understood that I need to somehow combine cities with their countries, because there might be cities with the same name in different countries. So far I have even been successfull in displaying my data on the map.

But then I became aware, that even in one country (e.g. Germany) there are different cities with the same names (e.g. Minden is a city near Hannover, but there is also a village called Minden near Echternach (Luxembourg) which is belonging to Germany as well.

Therefore I tried to use the Zip codes, and when the attribute's name is "zip" then Pyramid recognizes it as a geospatial information but does not display it in the map when it is combined with the country (which is only Germany). If I then remove the country, I see several bubbles in America, Africa, and so on (which is absolutely nonsense).

I then tried to rename the attribute to "PLZ" (which is the german abbreviation for zip) but this was neither recognised as a geospatial information by Pyramid nor has anything been displayed on the map.

What do I do wrong? Is longitude/latitude the only answer to this problem? Or how can I make sure, that Pyramid understands the combination of the country and the zip correctly?

Kind regards
Markus Loy

4 replies

    • Omri_Zach
    • 4 yrs ago
    • Reported - view

    Hello Markus,

    You have an option to focus the map only on one country:


    Please be noted that the 'Shape map' option for ZIP code is available only on the latest version 2020.03.027, available on the customer portal.

    You can see that the Attribute name is 'PLZ' and recognized well by Pyramid.

    Please let me know if you have further questions.

    • Angela_Music
    • 4 yrs ago
    • Reported - view

    What happens in the case of more than one country? How do the dimensions and measures have to be set in order for Pyramid to identify them correctly? (e.g. in my case PLZ is not recognized by Pyramid as a geospatial information (the small globe is missing).
    A combination of City, Country and ZIP code would ensure the most exact map. Thanks, BR Angela 

    • "making the sophisticated simple"
    • AviPerez
    • 4 yrs ago
    • Reported - view

    The general flow requires you to supply an attribute in your data model that designates country. Then you don't need to use the dialog box - which is a short cut for data models that don't have a country field. If you used a country attribute, you can supply any number of countries and their own specific zip code values. In this scenario, you'd use both the country and zip code attributes to get the right data in the right place.

    To set a field as geospatial, either set it in the modeling tools (yellow app); set it by role in the data source manager (admin tools); or set it for yourself from the Discover tools (green app) by right clicking on a field and setting its property.

    • Senior Consultant BI & Data Management
    • Markus_Loy
    • 4 yrs ago
    • Reported - view


    with version 2020.03 now everything works fine and without any further modifications.

    Thanks a lot for your help.

    Kind regards

Content aside

  • Status Answered
  • 4 yrs agoLast active
  • 4Replies
  • 101Views
  • 6 Following